找回密码
 立即注册
查看: 103|回复: 0

ovh家的机器好难用啊,装了5遍了,pve死活上不了zfs。

[复制链接]

750

主题

0

回帖

750

积分

00话痨hs000

积分
750
发表于 2023-8-10 03:51:34 | 显示全部楼层 |阅读模式
想直接在zfs上装pve。但每次装完就是进步了系统,死活卡在initramfs。

具体步骤如下:
# recuse下,跑个qemu,贴下我的启动项
qemu-system-x86_64 \
-enable-kvm \
-nodefaults \
-cdrom /root/proxmox-ve_7.4-1.iso \
-drive file=/dev/sda,format=raw,media=disk,if=virtio \
-drive file=/dev/sdb,format=raw,media=disk,if=virtio \
-drive file=/dev/sdc,format=raw,media=disk,if=virtio \
-drive file=/dev/sdd,format=raw,media=disk,if=virtio \
-cpu host \
-smp 4 \
-m 8G \
-net nic \
-net user \
-vga std \
-vnc 0.0.0.0:0 \
-usbdevice tablet \
-k en-us

因为四个盘外加一个cdrom,qemu不能用-hdc加载硬盘,和cdrom冲突,就用-drive了。进去后盘符会从sda变成vda,看了hetzner的文章,说没事,事实上我也没其他办法了。

这些都是常规操作,正常raidz1,结束,退出安装。

然后改grub,
GRUB_CMDLINE_LINUX="root=ZFS=rpool/ROOT/pve-1 boot=zfs net.ifnames=0 biosdevname=0"
延迟加载我也加入了,
GRUB_CMDLINE_LINUX_DEFAULT="rootdelay=10 quiet"

改interfaces 为eth0 也做了。

切换到hdd booting,进去就卡在initramfs界面了。含。

具体就是 mount :mounting on /root failed: Invalid argument
failed to mount as root file system

大概就是zfs池没加载估计。但我已经设置了delay了,还这样,即便手动加载了。貌似也没办法进入系统。
含,无奈了。准备卖掉这机器了。

然后我那hz的机器尝试了下zfs直装,一点问题没有啊。虽然只用了两块盘,手头没有四盘的机器。

ovh真的是折腾,大厂,含,还不如继续玩我的hz了。
[url=https://www.lates
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|翻墙党

GMT+8, 2026-10-1 07:49 , Processed in 0.057329 second(s), 23 queries .

Powered by Discuz! X3.5

© 2001-2026 Discuz! Team.

快速回复 返回顶部 返回列表